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Unable to delete directory in FTP or Plesk Server Administrator

Issue

When you try to delete a directory using FTP or the file manager in Plesk Server Administrator you receive an access denied message.

Cause

The issue can occur if the IIS Worker Process has a lock on the directory or files and folders contained within the directory. Until this lock is released it will be impossible to remove the directory.

Solution

The lock can be removed by recycling the IIS Worker Process using Plesk. Once recycled you can then delete the directory using either FTP or the Plesk file manager.

To recycle the Worker Process follow these steps:

  1. Login to Plesk Server Administrator.
  2. Select the domain name you are having the problem with.
  3. Click on the IIS Application Pool button.
  4. Click on the Recycle button.

After a few seconds the page will reload and the Work Process will have been recycled (however no confirmation of this is displayed). At this point you can delete the directory.

Get in touch

For any additional help, give us a call on 0800 477 333 (8AM to 10PM, 7 days a week).